summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2020-05-13 00:11:07 -0700
committerSean Greenslade2020-05-13 00:11:07 -0700
commit037ee6dea849c01d007da8ffa0e57455ab83e9f0 (patch)
tree3c49fae74a80b6bcdee87dcb62dda2b1468d0611 /PKGBUILD
parentf5a1d18b1df4ac64314b0862d768e5fdbd3be0b8 (diff)
downloadaur-037ee6dea849c01d007da8ffa0e57455ab83e9f0.tar.gz
Better way of creating var, now should have correct perms.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aeac2f3f1626..3f28ef83ba4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=weave-minimal
pkgname=$_pkgname-git
pkgver=1.5.r8.g503072a
-pkgrel=3
+pkgrel=4
pkgdesc="minimal weave 1.1 server for Pale Moon sync"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/zootboy/weave-minimal"
@@ -37,7 +37,7 @@ package() {
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
install -Dm644 $srcdir/$_pkgname/examples/weave-minimal.conf "$pkgdir/etc/weave-minimal.conf"
install -Dm644 $srcdir/$_pkgname/examples/weave-minimal.service "$pkgdir/usr/lib/systemd/system/weave-minimal.service"
- mkdir -p "$pkgdir/var/lib/weave/data"
+ install -Dm644 "$srcdir/99-weave-var.conf" "$pkgdir/usr/lib/tmpfiles.d/99-weave-var.conf"
python setup.py install --root="$pkgdir"
}