summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2020-02-12 13:00:31 -0800
committerSean Greenslade2020-02-12 13:00:31 -0800
commitb2f2ff122fdd61cc698e1909c7779d82d08f6a80 (patch)
tree535fa4603565dda35e267afe3e9104eb170b2a27 /PKGBUILD
parent6af4e9f9ac6792cef5bb0519ef15f5ad08ade738 (diff)
downloadaur-b2f2ff122fdd61cc698e1909c7779d82d08f6a80.tar.gz
Migrated systemd unit and example config to actual project git repo.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index feff79c0ba55..0bec7a75c381 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=weave-minimal
pkgname=$_pkgname-git
-pkgver=1.5.r5.g68ecf42
+pkgver=1.5.r7.gcaa5dba
pkgrel=1
pkgdesc="minimal weave 1.1 server for Pale Moon sync"
arch=('i686' 'x86_64' 'armv7h')
@@ -13,13 +13,9 @@ depends=('python' 'python-werkzeug')
optdepends=('python-gevent: better concurrency support')
provides=('weave-minimal')
conflicts=('weave-minimal')
-source=("git+https://github.com/zootboy/weave-minimal"
- "weave-minimal.conf"
- "weave-minimal.service")
+source=("git+https://github.com/zootboy/weave-minimal")
install=$_pkgname.install
-sha256sums=('SKIP'
- 'a0439ca506cfd442a2fd47e00688faa2e627dffe01c76083d91945ee38045077'
- '9cba600ecd1d1fd52270b4e6eef31dac0befe5726fc0137bbadd84b6c8ac69fc')
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -38,9 +34,9 @@ build() {
package() {
cd "$_pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 $srcdir/weave-minimal.conf "$pkgdir/etc/weave-minimal.conf"
- install -Dm644 $srcdir/weave-minimal.service "$pkgdir/usr/lib/systemd/system/weave-minimal.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 $srcdir/$_pkgname/examples/weave-minimal.conf "$pkgdir/etc/weave-minimal.conf"
+ install -Dm644 $srcdir/$_pkgname/examples/weave-minimal.service "$pkgdir/usr/lib/systemd/system/weave-minimal.service"
python setup.py install --root="$pkgdir"
}