diff options
author | Hanabishi | 2021-11-14 19:07:55 +0500 |
---|---|---|
committer | Hanabishi | 2021-11-14 19:07:55 +0500 |
commit | 76247b448194f87c093bff43f1ad7834bbcb953c (patch) | |
tree | 35d14b903fa64ccc3ab0c28cb4276e18fc476290 /PKGBUILD | |
parent | b7b0e391020c4daf91aabd07678ded7f640573b1 (diff) | |
download | aur-76247b448194f87c093bff43f1ad7834bbcb953c.tar.gz |
Minor pkgbuild cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -32,27 +32,27 @@ build() { npm i --omit=dev - tsc &>/dev/null | true + tsc | true } package() { cd "${srcdir}" - local bin="./${pkgname}" + local bin="${pkgname}" echo "#!/bin/sh" >"${bin}" echo "electron \"/usr/lib/${pkgname}/\" \$@" >>"${bin}" - install -Dm755 -t "${pkgdir}/usr/bin/" "${bin}" + install -Dm755 -t "${pkgdir}/usr/bin" "${bin}" - install -Dm644 "./app.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop" + install -Dm644 "app.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop" cd "${_srcname}" - install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" "./LICENSE" + install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "LICENSE" local lib="${pkgdir}/usr/lib/${pkgname}" - install -Dm644 -t "${lib}/" "./package.json" - cp -rt "${lib}/" "./sources/" "./node_modules/" + install -Dm644 -t "${lib}" "package.json" + cp -rt "${lib}" "sources" "node_modules" rm -r \ "${lib}/sources/app/.build" \ |