summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergej Pupykin2020-05-23 02:29:15 +0300
committerSergej Pupykin2020-05-23 02:29:15 +0300
commit0c079a512db711c824d18e9eaa313582e1a9ce1a (patch)
tree1ad94124053855125d5060e1def89e094cb79820 /PKGBUILD
downloadaur-0c079a512db711c824d18e9eaa313582e1a9ce1a.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e713c9e40155
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=webdav-daemon
+pkgver=v1.1.r1.bc88ec6
+pkgver() {
+ cd "WebDAV-Daemon"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+pkgrel=1
+pkgdesc="WebDAV server designed to be a replace for SMBA providing access to a system's files without taking ownership of them"
+arch=(x86_64)
+url="https://github.com/couling/WebDAV-Daemon"
+license=('MIT')
+depends=()
+makedepends=('git')
+backup=('etc/webdavd/conf.xml'
+ 'etc/logrotate.d/webdavd'
+ 'etc/pam.d/webdavd')
+source=("git+https://github.com/couling/WebDAV-Daemon.git"
+ build-fix.patch)
+md5sums=('SKIP'
+ 'a2ef51c60c732ed1a152606e1157568a')
+
+prepare() {
+ cd "WebDAV-Daemon"
+ patch -p1 -i "$srcdir/build-fix.patch"
+}
+
+build() {
+ cd "WebDAV-Daemon"
+ make
+}
+
+package() {
+ cd "WebDAV-Daemon"
+ install -dm0755 "$pkgdir/usr/share/webdavd"
+
+ install -Dm0644 package-with/conf.xml "$pkgdir/etc/webdavd/conf.xml"
+ install -Dm0644 package-with/logrotate.conf "$pkgdir/etc/logrotate.d/webdavd"
+ install -Dm0644 package-with/pam.conf "$pkgdir/etc/pam.d/webdavd"
+ install -Dm0644 package-with/systemd.service "$pkgdir/usr/lib/systemd/system/webdavd.service"
+ install -m0644 package-with/share/* "$pkgdir/usr/share/webdavd/"
+
+ install -Dm0644 useful/conf.xml "$pkgdir/etc/webdavd/conf.xml.example"
+
+ install -Dm0755 build/rap "$pkgdir/usr/bin/rap"
+ install -Dm0755 build/webdavd "$pkgdir/usr/bin/webdavd"
+}