summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorminus2018-10-05 16:52:39 +0200
committerminus2018-10-05 16:52:39 +0200
commit65cbdecd3971c45aee2104e2ed204bb3577ed6f5 (patch)
tree49e3e7760dc3bfb5465d989cfd41adcb2f0a16c0 /PKGBUILD
parent77291cb290cb450d2d7068cb2dcdb33112bec3fb (diff)
downloadaur-65cbdecd3971c45aee2104e2ed204bb3577ed6f5.tar.gz
Update to 0.1.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73f3e0ec764d..713473a403bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,28 @@
# Contributor: pandan <predrg@gmail.com>
pkgname=webdis
-pkgver=0.1.3
+pkgver=0.1.4
pkgrel=1
pkgdesc='REST server for Redis data'
arch=('x86_64' 'i686')
url='https://webd.is/'
license=('BSD')
depends=('redis' 'libevent' 'jansson')
-makedepends=('git')
install='webdis.install'
-source=("webdis::git://github.com/nicolasff/webdis.git#tag=$pkgver"
+source=("https://github.com/nicolasff/webdis/archive/$pkgver.tar.gz"
'webdis.service'
'webdis.logrotate')
-sha256sums=('SKIP'
+sha256sums=('2e384eae48cfc2e4503e3311c61d4790e5d3b3ab5cf82ec554c0bef5d84c6807'
'3c77e6968a0926c8b56755acab430f32c3e883f50b2f6f59d4dce2501bf247a7'
'f409fefee8533e60db6a6340c021b77b57f55cfcbf26ae4acdc3b672c7aa79b7')
-pkgver() {
- cd "${pkgname%-git}"
-
- git describe --tags
-}
-
build() {
- make -C "${pkgname%-git}" LDFLAGS+="-levent -pthread" \
+ make -C "$pkgname" LDFLAGS+="-levent -pthread" \
CFLAGS+="-I. -Ihttp-parser -Iformats -Ijansson/src"
}
package() {
- cd "${pkgname%-git}"
+ cd "$pkgname"
make DESTDIR="$pkgdir" PREFIX=/usr install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/webdis/COPYING"