summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2022-09-22 15:59:02 +0200
committerJ. Nathanael Philipp2022-09-22 15:59:02 +0200
commit281e0bb96b74d009fac68b77bcbbdff9ad50cd88 (patch)
tree878330cf7c735dced6357e73ba88f93236233e5e /PKGBUILD
parent3860f11a15f06bb43c85d8a75efb6d71e5bd79d8 (diff)
downloadaur-281e0bb96b74d009fac68b77bcbbdff9ad50cd88.tar.gz
Version 2.1.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 825c682e0e2f..2bb75da8c5f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,21 @@
pkgname=webledger
_pkgname=${pkgname#web}
provides=(${_pkgname})
-pkgver=2.1.7
+pkgver=2.1.8
pkgrel=1
pkgdesc="Web based ledger system"
arch=("any")
url="https://github.com/jnphilipp/ledger"
license=("GPL3+")
makedepends=("git" "help2man" "python" "python-virtualenv")
-depends=("python" "python-django" "python-gobject" "python-dbus" "systemd" "uwsgi" "uwsgi-plugin-python")
-source=("git+https://github.com/jnphilipp/ledger.git"
- "git+https://github.com/jnphilipp/django_bootstrap5.git")
-md5sums=(SKIP SKIP)
-
-prepare() {
- cd "$srcdir/$_pkgname"
- git submodule init
- git config submodule.django-bootstrap5.url $srcdir/django-bootstrap5
- git submodule update
-}
+depends=("python" "python-django" "python-gobject" "python-dbus" "python-django_bootstrap5" "systemd" "uwsgi" "uwsgi-plugin-python")
+source=("git+https://github.com/jnphilipp/ledger.git")
+md5sums=(SKIP)
check() {
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd "$srcdir/$_pkgname"
git checkout $pkgver
make clean
- make venv PYTHON_LIB_DIR=$site_packages
make test
}