summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-20 12:58:12 +0000
committerGrey Christoforo2016-01-20 12:58:12 +0000
commit4e0f95cb30c6c436be32ce7f51f1d95b22bc6961 (patch)
tree348237d949561a25570cb22f3b10a369b418a2e1 /PKGBUILD
parente2e5ced9c4eeaa23a9e2a1dff99163b27a32ea2d (diff)
downloadaur-weblogo.tar.gz
still need to do the python part of the install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b981e9c004a2..51012ef3a6d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,33 @@ pkgname=weblogo
pkgver=3.4.1
pkgrel=1
pkgdesc="A web based application designed to make the generation of sequence logos as easy and painless as possible"
-url="http://weblogo.berkeley.edu//"
+url="http://weblogo.threeplusone.com"
arch=('i686' 'x86_64')
license=('custom (MIT)')
+optdepends=('python')
depends=('ghostscript')
source=("https://github.com/WebLogo/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=('7201942b419ca8fbb9395a11b0e34f9c')
#options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
-prepare(){
-msg "preparing"
-}
-
build(){
msg "building"
+#TODO: build the python stuff
}
package() {
-msg "packaging"
+#TODO: install the python stuff
+
+# put the src into opt
+mkdir -p "${pkgdir}/opt/${pkgname}"
+cp -a ${srcdir}/${pkgname}-${pkgver}/* "${pkgdir}/opt/${pkgname}/."
+
+# link the exe
+mkdir -p ${pkgdir}/usr/bin
+ln -s /opt/${pkgname}/weblogo ${pkgdir}/usr/bin/.
+
+# install license file
+install -m644 -D "${srcdir}/${pkgname}-${pkgver}/LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et:#