summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquín Pino2022-04-07 13:36:52 -0500
committerJoaquín Pino2022-04-07 13:36:52 -0500
commit8822a4d8254f13d9d6d2bbaf816aaa292bdf833b (patch)
tree43be32ff582186b6f5dd96cd88f82d35ad4ea1c4 /PKGBUILD
downloadaur-8822a4d8254f13d9d6d2bbaf816aaa292bdf833b.tar.gz
first commit to webp-pixbuf-loader-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6073d9c0287e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_name="webp-pixbuf-loader"
+pkgname="${_name}-git"
+pkgdesc="Enable WebP support in GTK apps"
+pkgver=2022.03.16
+pkgrel=1
+url="https://github.com/aruiz/webp-pixbuf-loader"
+license=("GPL")
+depends=("gdk-pixbuf2" "libwebp")
+makedepends=("meson")
+arch=("i686" "x86_64")
+conflicts=("${_name}")
+source=("${_name}::git+${url}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ git log -1 --format="%cd" --date=short | sed 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_name}"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/${_name}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}