summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRay Song2016-04-11 21:40:29 +0800
committerRay Song2016-04-11 21:40:29 +0800
commit104458f69aae08a37c819e40d108bd0e3082feef (patch)
tree93016f38ae03d2c3b48003e5b720663c35341873 /PKGBUILD
downloadaur-104458f69aae08a37c819e40d108bd0e3082feef.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03e46f5690f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ray Song <i at maskrayme dot me>
+
+pkgname=webqqircd-git
+_pkgname=webqqircd
+pkgver=r1.f8565e3
+pkgrel=1
+pkgdesc="IRC server capable of controlling WebQQ (w.qq.com)"
+arch=('i686' 'x86_64')
+url="https://github.com/MaskRay/webqqircd"
+license=('MIT')
+depends=('python-aiohttp')
+optdepends=("python-ipython: pretty error messages with the '-d' option")
+makedepends=('git')
+provides=('webqqircd')
+conflicts=('webqqircd')
+source=('git+https://github.com/MaskRay/webqqircd.git' webqqircd.service install)
+install=install
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -D "$_pkgname/webqqircd.py" "$pkgdir/usr/bin/webqqircd"
+ install -Dm644 "$_pkgname/mq.js" -t "$pkgdir/usr/share/webqqircd/"
+ install -Dm644 webqqircd.service -t "$pkgdir/usr/lib/systemd/system/"
+}