summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzoorat2023-11-11 19:01:17 +0600
committerzoorat2023-11-11 19:01:17 +0600
commit580e1cef3580887f11d4299d81359bdd6076ea6c (patch)
tree689215320f1476040edd28b2875045d79a1efc24 /PKGBUILD
parentf337995ade5bb2a8487c3385530d216956f7300f (diff)
downloadaur-580e1cef3580887f11d4299d81359bdd6076ea6c.tar.gz
adding better tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fedb55ab94c..bef101b1c1e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
_npmname=bittorrent-tracker
pkgname=webtorrent-$_npmname
pkgver=11.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, robust, BitTorrent tracker (client & server) implementation"
-arch=(any)
+arch=('x86_64')
url="https://github.com/webtorrent/bittorrent-tracker"
license=("MIT")
-depends=("nodejs")
+depends=("glibc" "nodejs")
makedepends=("npm" "jq")
# provides=("$_npmname")
# conflicts=("$_npmname")
options=(strip emptydirs zipman)
+changelog="changelog.md"
source=("https://registry.npmjs.org/${_npmname}/-/${_npmname}-${pkgver}.tgz"
"https://raw.githubusercontent.com/webtorrent/bittorrent-tracker/master/LICENSE")
noextract=("${_npmname}-${pkgver}.tgz")
b2sums=('02d37df390b98b14e5298bcd03454eb16376c3b5bedc9a41359b08903ef03f37ee2b18eac46896c380faa07bba8a4f42efa65d63d3696dcf0cf2741556960469'
- '3890a8cd095787f6ab383fe3ca0a0bf0999d80a7ea65627bb1a50f1c2690987f53e0619df5745ba47d6ef46d32e03573b5a52330a7c857220e4db96a33203019')
+ '3890a8cd095787f6ab383fe3ca0a0bf0999d80a7ea65627bb1a50f1c2690987f53e0619df5745ba47d6ef46d32e03573b5a52330a7c857220e4db96a33203019')
# Document: https://wiki.archlinux.org/title/Node.js_package_guidelines
package() {
@@ -28,8 +29,7 @@ package() {
npm install -s -g \
--cache "${srcdir}/npm-cache" \
--prefix "${pkgdir}/usr" \
- "${srcdir}/${_npmname}-${pkgver}.tgz" \
- --loglevel verbose
+ "${srcdir}/${_npmname}-${pkgver}.tgz"
# Fix ownership of ALL FILES
find "${pkgdir}/usr" -type d -exec chmod 755 {} +