summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsuliman altassan2021-07-13 17:23:22 +0300
committersuliman altassan2021-07-13 17:23:22 +0300
commit9dafcacdfcc8b55719425079a7e30311256d62e4 (patch)
tree851d55407ef0373b5ca9cdaf0dece4e414340181 /PKGBUILD
parent19cb8fff524b47056512ac9e5a38aa6a05bf6ef3 (diff)
downloadaur-9dafcacdfcc8b55719425079a7e30311256d62e4.tar.gz
boost is only required to build
cmake and git also required to build prefix should be /usr, not /usr/local https://wiki.archlinux.org/title/Arch_package_guidelines#Directories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21b4fd2f2fb4..1ef3439d6a58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: suliman altassan <suliman.p2019@gmail.com>
pkgname=webui-git
-pkgver=r18.db0a6b6
-pkgrel=0
+pkgver=r20.594a909
+pkgrel=1
pkgdesc="Open source project to use web browsers as UI."
arch=('x86_64')
url="https://github.com/alifcommunity/webui/"
license=('LGPL3')
-depends=('boost')
+makedepends=('boost' 'cmake' 'git')
conflicts=('webui')
provides=('webui')
source=("$pkgname"::"git+https://github.com/alifcommunity/webui.git")
@@ -20,7 +20,7 @@ pkgver() {
build() {
cd $srcdir/$pkgname
- cmake . . -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/local
+ cmake . . -DCMAKE_INSTALL_PREFIX=$pkgdir/usr
make
}