summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyril Levis2021-04-18 17:34:46 +0200
committerCyril Levis2021-04-18 17:34:46 +0200
commit6217095a2ed29798b8cc7c35fd8b0bebde09aeaf (patch)
tree64e8fc9bf70cfff907d8933f479f0a77d674bcdb /PKGBUILD
parent94dc8742cd914453ad9706f1e64a3bd5fca00b2b (diff)
downloadaur-6217095a2ed29798b8cc7c35fd8b0bebde09aeaf.tar.gz
upgpkg: webwormhole-git r195.1c8919c-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b89c0dea1bac..0cae8c051496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=webwormhole-git
_pkgname=${pkgname%-git}
pkgver=r195.1c8919c
-pkgrel=2
+pkgrel=3
pkgdesc='WebWormhole creates ephemeral pipes between computers to send files or other data.'
arch=('x86_64')
url="https://github.com/saljam/${_pkgname}"
@@ -33,6 +33,7 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-trimpath -mod=readonly -modcacherw"
GOOS=js GOARCH=wasm go build -o ./web/webwormhole.wasm ./web
+ cp "$(go env GOROOT)/misc/wasm/wasm_exec.js" ./web/wasm_exec.js
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
GO111MODULE=on go build ./cmd/ww
}