summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOskar Grunning2018-10-18 21:37:10 +0200
committerOskar Grunning2018-10-18 21:37:10 +0200
commit5ca665a0f5a6ba2095f927624574b525fcf56f13 (patch)
tree6ff6ed1e8b469f2327e2471f527448d353afb5a8 /PKGBUILD
downloadaur-5ca665a0f5a6ba2095f927624574b525fcf56f13.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60a07803b4cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+arch=('any')
+depends=('weechat' 'libnotify')
+license=('MIT')
+sha512sums=('SKIP')
+pkgdesc='A WeeChat script that sends highlight and message notifications through notify-send'
+pkgname=weechat-notify-send
+pkgrel=1
+pkgver=r180.962218a
+source=('git+https://github.com/s3rvac/weechat-notify-send.git')
+makedepends=('git')
+url='https://github.com/s3rvac/weechat-notify-send'
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm644 "notify_send.py" "${pkgdir}/usr/lib/weechat/python/notify_send.py"
+}