summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Schantl2023-10-06 11:01:12 +0000
committerMichael Schantl2023-10-06 11:01:12 +0000
commit546d0b8165011a7be52e9fee3249524a7b6a54c1 (patch)
tree560e08be2aa58d12ef6fb565e2b790e49c840a34 /PKGBUILD
parent47cf89105afb918583ae42af4eeb25658181a52a (diff)
downloadaur-546d0b8165011a7be52e9fee3249524a7b6a54c1.tar.gz
upgpkg: weewx 4.10.2-7
Fix missing patch for `bin/weeplot/utilities.py` file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40b7f125399e..40a6e47a4714 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ function _dl_url {
echo "https://github.com/weewx/weewx/archive/refs/tags/v$1.$2.$3.tar.gz"
}
-pkgrel=6
+pkgrel=7
pkgdesc="Software for logging data from weather stations"
arch=("any")
url="http://www.weewx.com/"
@@ -42,7 +42,8 @@ source=("$pkgname-$pkgver.tar.xz::$(_dl_url $_MAJOR $_MINOR $_PATCH)"
"wunderfixer"
"weewx.service"
"genplot.py"
- "weewx-version.patch")
+ "weewx-version.patch"
+ "pillow-rect.patch")
sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6e699cf1c3a0d5505c89ad8c309517db32fd8dc4a0ae4704dfd5ed0cc5747f'
'SKIP'
'SKIP'
@@ -54,13 +55,15 @@ sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
_watch="http://www.weewx.com/downloads/"
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
patch --strip=1 --input="$srcdir/weewx-version.patch"
+ patch --strip=1 --input="$srcdir/pillow-rect.patch"
cp -v "$srcdir/genplot.py" bin/weeplot
}