summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Schantl2021-03-13 13:58:26 +0000
committerMichael Schantl2021-03-13 13:58:26 +0000
commitb6b23ea7b715d50e689cf9c708560eca89bdf5fe (patch)
tree0f2b73bd26900673e0893f23b3f698cc1fd359ca /PKGBUILD
parent4e06cc0d8675b280c047d158d792d34b68e62ea4 (diff)
downloadaur-b6b23ea7b715d50e689cf9c708560eca89bdf5fe.tar.gz
Allow for automatic update checking
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61d9fa2d4e67..def317187a69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,18 @@
# Maintainer: Michael Schantl <floss at schantl dash lx dot at>
# Upstream authors: Tom Keffer, Matthew Wall and contributors
+# Supports automatic update checking
+
pkgname=weewx
-pkgver=4.4.0
+_MAJOR=4
+_MINOR=4
+_PATCH=0
+pkgver=$_MAJOR.$_MINOR.$_PATCH
+
+function _dl_url {
+ echo "http://www.weewx.com/downloads/released_versions/${pkgname}-$1.$2.$3.tar.gz"
+}
+
pkgrel=1
pkgdesc="Software for logging data from weather stations"
arch=("any")
@@ -20,7 +30,7 @@ optdepends=("python-pyephem: extended almanac information"
"mariadb-clients: MariaDB support"
"python-mysqlclient: MariaDB support")
backup=("etc/weewx/weewx.conf")
-source=("http://www.weewx.com/downloads/released_versions/${pkgname}-${pkgver}.tar.gz"
+source=("$(_dl_url $_MAJOR $_MINOR $_PATCH)"
"wee_config"
"wee_database"
"wee_debug"