summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Schantl2023-05-10 16:54:47 +0000
committerMichael Schantl2023-05-10 16:54:47 +0000
commite043e95507fc89175d96c045efc3602252768486 (patch)
treea4f8e9dd7ad49d7d532d76a64afdae3b9b7d3873 /PKGBUILD
parent6e5cf3e31f3ecd5fc70830f56d0dc8e744389bd1 (diff)
downloadaur-e043e95507fc89175d96c045efc3602252768486.tar.gz
Add patch for breaking change in Pillow
Applies commit 48f6053 from upstream repository.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64cc0423d450..13f8f44e6ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ function _dl_url {
echo "https://github.com/weewx/weewx/archive/refs/tags/v$1.$2.$3.tar.gz"
}
-pkgrel=2
+pkgrel=3
pkgdesc="Software for logging data from weather stations"
arch=("any")
url="http://www.weewx.com/"
@@ -40,7 +40,8 @@ source=("$pkgname-$pkgver.tar.xz::$(_dl_url $_MAJOR $_MINOR $_PATCH)"
"wee_reports"
"weewxd"
"wunderfixer"
- "weewx.service")
+ "weewx.service"
+ "pillow-rect.patch")
sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6e699cf1c3a0d5505c89ad8c309517db32fd8dc4a0ae4704dfd5ed0cc5747f'
'SKIP'
'SKIP'
@@ -51,9 +52,15 @@ sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP')
_watch="http://www.weewx.com/downloads/"
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch --strip=1 --input="$srcdir/pillow-rect.patch"
+}
+
build() {
cd "$srcdir/${pkgname}-${pkgver}"
python setup.py build