diff options
author | Aaron Mueller | 2014-07-14 10:21:03 +0200 |
---|---|---|
committer | Aaron Mueller | 2014-07-14 10:21:03 +0200 |
commit | 8b34123e52dbf20ee4ab1eb3e8788c64006ca667 (patch) | |
tree | fa7accfa3b494c0ca0a39a3d52eabfac044757d0 /PKGBUILD | |
parent | 76b625b68889745aed6b199632c00f28861d41f8 (diff) | |
download | aur-8b34123e52dbf20ee4ab1eb3e8788c64006ca667.tar.gz |
Fix the weex package (https://bbs.archlinux.org/viewtopic.php?id=184195)
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 29 |
1 files changed, 19 insertions, 10 deletions
@@ -1,33 +1,42 @@ # Contributor: Tom Newsom <Jeepster@gmx.co.uk> # Contributor: Giorgio Lando <patroclo7@gmail.com> +# Contributor: falconindy <d@falconindy.com> # Maintainer: Aaron Mueller <mail@aaron-mueller.de> pkgname=weex pkgver=2.6.1.5 -pkgrel=5 +pkgrel=6 pkgdesc="A non-interactive FTP client for updating web pages" arch=(i686 x86_64) license=("GPL") source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz" - "http://git.sv.gnu.org/gitweb/?p=gnulib.git;a=blob_plain;f=lib/regex.h" "weex-2.6.1.5-formatstring.patch" "weex-2.6.1.5-va_list.patch") md5sums=("c10192608ab9f715c4c1ea63cf6ad2da" - "63dc5065aa90e787153804229e7da1c2" "a12d955c5a4d6b059395a0da22942114" "522552e03b82ab5669fd21c558290691") url="http://weex.sourceforge.net/" -build() { - cd $startdir/src/$pkgname-$pkgver +prepare() { + cd "$pkgname-$pkgver" patch -Np0 -i ../weex-$pkgver-formatstring.patch - [ "$CARCH" == "x86_64" ] && patch -Np0 -i ../weex-$pkgver-va_list.patch + [[ $CARCH == x86_64 ]] && patch -Np0 -i ../weex-$pkgver-va_list.patch +} + +build() { + cd "$pkgname-$pkgver" - # Fix the missing header file, hanks to mibli. - cp $startdir/src/regex.h $startdir/src/$pkgname-$pkgver/lib_regex.h + # work around problems in ancient autotools installation + unset CPPFLAGS + CFLAGS+=' -D_FORTIFY_SOURCE=2' ./configure --prefix=/usr - make || return 1 - make prefix=$startdir/pkg/usr install + make +} + +package() { + cd "$pkgname-$pkgver" + + make DESTDIR="$pkgdir" install } |