summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Wanders2019-01-20 17:48:35 +0100
committerTim Wanders2019-01-20 17:48:35 +0100
commit06ce0f171a09a98d778a3593d8baaa988fda9550 (patch)
tree439df71b1279d817e6ae11ee0e66e3cb45f9cbce /PKGBUILD
parentfc13349afed3f482efd4e1d331a7866a75c20d82 (diff)
downloadaur-06ce0f171a09a98d778a3593d8baaa988fda9550.tar.gz
Split elkhound and weidu
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4128ae47e34a..7c95d7e38608 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
_pkgname=weidu
pkgname=$_pkgname-git
-pkgver=1
+pkgver=git
pkgrel=1
-makedepends=("ocaml")
+makedepends=("ocaml" "elkhound-git")
arch=("x86_64")
conflicts=("weidu-bin" "weidu")
@@ -13,10 +13,9 @@ pkgdesc="WeiDU is a program used to develop, distribute and install modification
license=("GPLv2")
-source=("git+https://github.com/WeiDUorg/elkhound"
- "git+https://github.com/WeiDUorg/weidu#branch=devel")
+source=("git+https://github.com/WeiDUorg/weidu#branch=devel")
-sha256sums=("SKIP" "SKIP")
+sha256sums=("SKIP")
pkgver() {
cd "$srcdir/weidu"
@@ -24,21 +23,13 @@ pkgver() {
}
prepare() {
- cd "$srcdir/elkhound/src"
- ./configure
-
cd "$srcdir/weidu"
cp sample.Configuration Configuration
}
build() {
- cd "$srcdir/elkhound/src"
- make -j1
- cd "$srcdir/weidu"
- export PATH="$srcdir/elkhound/src/elkhound:$PATH"
- export OCAMLPARAM="safe-string=0,_"
-
+ cd "$srcdir/weidu"
make -j1
}