summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsukanka2022-12-08 00:58:05 +0800
committersukanka2022-12-08 00:58:05 +0800
commit34c5a056e5883d654864eaa02c2730047f8c514d (patch)
treee385a112d8ff2053d2e76ce01d95fac037c11a1d /PKGBUILD
parente943961c434cec6afd2e77a04826027f8c7e6ff7 (diff)
downloadaur-34c5a056e5883d654864eaa02c2730047f8c514d.tar.gz
fix package()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d52c4cc368f..6594973e1845 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgver=3.12.0.400
_pkgver_arm=3.11.0.402 # 两个版本有时候不一样
_x86_md5=e078bf97365540d9f0ff063f93372a9c
_arm_md5=ce5d25cc8e8aae8ddd19295bc3b00d5e
-pkgrel=1
+pkgrel=2
pkgdesc="Tencent Video Conferencing, tencent meeting 腾讯会议"
arch=('x86_64' 'aarch64')
license=('unknown')
@@ -58,13 +58,13 @@ package() {
install -Dm755 "${srcdir}/${_pkgname}".sh ${pkgdir}/usr/bin/${_pkgname}
install -Dm644 ${_pkgname}.svg -t ${pkgdir}/usr/share/icons/hicolor/scalable/apps/
- _preserved_libs="ImSDK,desktop_common,nxui*,qt_*,ui*,wemeet*,xcast,xcast_codec,xnn*"
+ install -Dm755 lib/lib{ImSDK,desktop_common,nxui*,qt_*,ui*,wemeet*,xcast,xcast_codec,xnn*}.so \
+ -t ${pkgdir}/usr/lib/${_pkgname}
+
if [ $(uname -m) = 'x86_64' ]; then
# arm 落后一个版本,没有这个
- _preserved_libs="${_preserved_libs},service*"
+ install -Dm755 lib/libservice*.so -t ${pkgdir}/usr/lib/${_pkgname}
fi
- install -Dm755 lib/lib{${_preserved_libs}}.so \
- -t ${pkgdir}/usr/lib/${_pkgname}
for lib in ${pkgdir}/usr/lib/${_pkgname}/*
do