summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchadept2016-05-29 22:46:05 +0200
committerArchadept2016-05-29 22:46:05 +0200
commit51370eecf2a920b2b9e7eb067545dae65bed5758 (patch)
treeb0221988c42cac115e22d3ba044a8ca19a90d982 /PKGBUILD
parentb69f16fcb9811a9a75b216b366e7a52cd6e8e0f9 (diff)
downloadaur-51370eecf2a920b2b9e7eb067545dae65bed5758.tar.gz
Switched back to cmake build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15ec7fe4cbd1..8f05d1d7cb07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Archadept
-# Revision: 2016-03-15
+# Revision: 2016-05-29
pkgname=wesnoth-git
_gitname=wesnoth
-pkgver=1.13.4.104.g3f58231
+pkgver=1.13.4.830.g617d22e
pkgrel=1
pkgdesc="The latest version of a turn-based strategy game on a fantasy world"
arch=('x86_64')
url="http://www.wesnoth.org/"
license=('GPL')
depends=('boost' 'boost-libs' 'fribidi' 'sdl2' 'sdl2_ttf' 'sdl2_net' 'sdl2_mixer' 'sdl2_image' 'libvorbis' 'pango' 'python')
-makedepends=('openssh' 'scons' 'git')
-conflicts=('wesnoth' 'wesnoth-data' 'wesnoth-devel')
+makedepends=('openssh' 'cmake' 'git' 'gcc')
+conflicts=('wesnoth' 'wesnoth-data')
provides=('wesnoth')
source=('git://github.com/wesnoth/wesnoth.git')
@@ -30,12 +30,9 @@ build() {
}
package() {
- cd ${_gitname}-build
+ cd "$srcdir/$_gitname-build/cmake"
- scons prefsdir=.config/$pkgname prefix=/usr debug=yes || return 1
- scons destdir=${pkgdir} install || return 1
-
- cd ${pkgdir}
-
- rm -R var
+ cmake .. -DPREFERENCES_DIR=.local/share/wesnoth/git -DCMAKE_INSTALL_PREFIX=$pkgdir/usr
+ make
+ make install
}