summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThayne McCombs2023-04-22 01:28:21 -0600
committerThayne McCombs2023-04-22 01:28:21 -0600
commitdc64e61cd969834a906148df10a093fc2d15c059 (patch)
tree9af8d5d0fab3dddd677d15bd116dd13c944a9fba /PKGBUILD
parente50023a9b58d62db3caa6de07a7672a4fb9f3d1b (diff)
downloadaur-dc64e61cd969834a906148df10a093fc2d15c059.tar.gz
upgpkg: wev 1.0.0-11
Go back to using the tarball, but skip the checksum
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 332f37afce27..5dbf6c59d289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Thayne McCombs <astrothayne at gmail dot com>
pkgname=wev
pkgver=1.0.0
-pkgrel=10
+pkgrel=11
pkgdesc="tool for debugging wayland events, similar to xev"
url='https://git.sr.ht/~sircmpwn/wev'
license=(MIT)
arch=('i686' 'x86_64' 'aarch64')
depends=('wayland' 'libxkbcommon')
-makedepends=('git' 'scdoc' 'wayland-protocols')
+makedepends=('scdoc' 'wayland-protocols')
conflicts=('wev-git')
-source=(git+https://git.sr.ht/~sircmpwn/wev#tag=$pkgver)
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~sircmpwn/wev/archive/$pkgver.tar.gz")
+# The package checksum isn't stable, so skip the checksum
+# since we download from https, the main risk here is if sourcehut changes the
+# contents of the package archive
+sha256sums=('SKIP')
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make CFLAGS="$CFLAGS $LDFLAGS"
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" PREFIX=/usr MANDIR=/usr/share/man install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha256sums=('SKIP')