summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Bergmark2023-01-26 20:12:01 +0100
committerWez Furlong2023-01-26 16:18:29 -0700
commit413a7ab5e706835f900acd4022ba5b2c38031694 (patch)
tree4dcdcddebf6e175ee60e562536789b49076f8348 /PKGBUILD
parent298dac5a60040179e5b3a0fd0d9a8d40e96e7900 (diff)
downloadaur-413a7ab5e706835f900acd4022ba5b2c38031694.tar.gz
Reformat script file to prevent mistakes
Although on a standard configuration `makepkg` might use directories without any spaces or special characters, these directores can be overridden on some user's machines. Quoting variables that may contain spaces prevents that from causing incorrect output. Also exit if a `cd` fails for any reason. Bumped all versions in the script.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc071eca41a4..6b85d222eda6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=("wezterm-git")
pkgdesc="A terminal emulator implemented in Rust, using OpenGL ES 2 for rendering."
-pkgver=20210916.085405.e36cf754
-pkgrel=3
+pkgver=20230125.180646.f15bb186
+pkgrel=1
arch=("x86_64" "i686")
url="https://github.com/wez/wezterm"
license=("MIT")
@@ -32,40 +32,40 @@ source=(
sha256sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP")
prepare() {
- cd $srcdir/wezterm
+ cd "$srcdir/wezterm"
git submodule init
- git config -f .gitmodules "submodule.harfbuzz/harfbuzz.url" $srcdir/harfbuzz
- git config -f .gitmodules "submodule.freetype/libpng.url" $srcdir/libpng
- git config -f .gitmodules "submodule.deps/freetype/zlib.url" $srcdir/zlib
- git config -f .gitmodules "submodule.freetype2.url" $srcdir/freetype2
+ git config -f .gitmodules "submodule.harfbuzz/harfbuzz.url" "$srcdir/harfbuzz"
+ git config -f .gitmodules "submodule.freetype/libpng.url" "$srcdir/libpng"
+ git config -f .gitmodules "submodule.deps/freetype/zlib.url" "$srcdir/zlib"
+ git config -f .gitmodules "submodule.freetype2.url" "$srcdir/freetype2"
git submodule update
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
pkgver() {
- cd $srcdir/wezterm
+ cd "$srcdir/wezterm" || exit 1
git -c "core.abbrev=8" show -s "--format=%cd-%h" "--date=format:%Y%m%d-%H%M%S" | tr - .
}
build() {
- cd $srcdir/wezterm
+ cd "$srcdir/wezterm" || exit 1
bash ci/check-rust-version.sh
cargo build --frozen --release
tic -x -o "$srcdir/terminfo" "$srcdir/wezterm/termwiz/data/wezterm.terminfo"
}
package() {
- cd $srcdir/wezterm
+ cd "$srcdir/wezterm" || exit 1
- install -Dsm755 target/release/wezterm $pkgdir/usr/bin/wezterm
- install -Dsm755 target/release/wezterm-gui $pkgdir/usr/bin/wezterm-gui
- install -Dsm755 target/release/wezterm-mux-server $pkgdir/usr/bin/wezterm-mux-server
- install -Dsm755 target/release/strip-ansi-escapes $pkgdir/usr/bin/strip-ansi-escapes
+ install -Dsm755 target/release/wezterm "$pkgdir/usr/bin/wezterm"
+ install -Dsm755 target/release/wezterm-gui "$pkgdir/usr/bin/wezterm-gui"
+ install -Dsm755 target/release/wezterm-mux-server "$pkgdir/usr/bin/wezterm-mux-server"
+ install -Dsm755 target/release/strip-ansi-escapes "$pkgdir/usr/bin/strip-ansi-escapes"
- install -Dm644 assets/icon/terminal.png $pkgdir/usr/share/icons/hicolor/128x128/apps/org.wezfurlong.wezterm.png
- install -Dm644 assets/wezterm.desktop $pkgdir/usr/share/applications/org.wezfurlong.wezterm.desktop
- install -Dm644 assets/wezterm.appdata.xml $pkgdir/usr/share/metainfo/org.wezfurlong.wezterm.appdata.xml
- install -Dm644 assets/wezterm-nautilus.py $pkgdir/usr/share/nautilus-python/extensions/wezterm-nautilus.py
+ install -Dm644 assets/icon/terminal.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/org.wezfurlong.wezterm.png"
+ install -Dm644 assets/wezterm.desktop "$pkgdir/usr/share/applications/org.wezfurlong.wezterm.desktop"
+ install -Dm644 assets/wezterm.appdata.xml "$pkgdir/usr/share/metainfo/org.wezfurlong.wezterm.appdata.xml"
+ install -Dm644 assets/wezterm-nautilus.py "$pkgdir/usr/share/nautilus-python/extensions/wezterm-nautilus.py"
install -Dm644 ../terminfo/w/wezterm "$pkgdir/usr/share/terminfo/w/wezterm"
install -Dm644 assets/shell-integration/wezterm.sh "$pkgdir/etc/profile.d/wezterm.sh"
@@ -75,4 +75,3 @@ package() {
install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-