summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBernát Gábor2021-08-06 17:47:46 +0100
committerBernát Gábor2021-08-06 18:39:10 +0100
commit9887623949467b2ec0dad81ab8a2b89ab91927a0 (patch)
tree13c84f7b85fb675af89937d93bc4c579b4648af0 /PKGBUILD
parentbd212320550eefd5551ee02e5d80417cdd04565a (diff)
downloadaur-9887623949467b2ec0dad81ab8a2b89ab91927a0.tar.gz
Allow to cache submodules
Signed-off-by: Bernát Gábor <gaborjbernat@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 31 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 642b678975f6..ce431c94cb4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,47 @@
# Maintainer: Wez Furlong <wez at wezfurlong dot org>
-pkgname=('wezterm-git')
+pkgname=("wezterm-git")
pkgdesc="A terminal emulator implemented in Rust, using OpenGL ES 2 for rendering."
-pkgver=20200517.122836.92c201c6.105.g5d508350
-pkgrel=5
-arch=('x86_64' 'i686')
+pkgver=20210806.095157.40bb5ddb
+pkgrel=1
+arch=("x86_64" "i686")
url="https://github.com/wez/wezterm"
-license=('MIT')
+license=("MIT")
depends=(
- 'dbus'
- 'fontconfig'
- 'hicolor-icon-theme'
- 'libx11'
- 'libxkbcommon-x11'
- 'wayland'
- 'xcb-util-image'
- 'xcb-util-keysyms'
- 'xcb-util-wm'
+ "dbus"
+ "fontconfig"
+ "hicolor-icon-theme"
+ "libx11"
+ "libxkbcommon-x11"
+ "wayland"
+ "xcb-util-image"
+ "xcb-util-keysyms"
+ "xcb-util-wm"
)
-makedepends=('rust' 'cargo' 'cmake' 'git' 'pkgconf' 'python')
-source=("git+https://github.com/wez/wezterm.git")
-sha256sums=('SKIP')
-conflicts=('wezterm-bin' 'wezterm-nightly-bin')
+makedepends=("rust" "cargo" "cmake" "git" "pkgconf" "python")
+source=(
+ "wezterm::git+https://github.com/wez/wezterm.git"
+ "harfbuzz::git+https://github.com/harfbuzz/harfbuzz.git"
+ "libpng::git+https://github.com/glennrp/libpng.git"
+ "zlib::git+https://github.com/madler/zlib.git"
+ "freetype2::git+https://github.com/wez/freetype2.git"
+)
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP")
+conflicts=("wezterm-bin" "wezterm-nightly-bin")
prepare() {
cd $srcdir/wezterm
- git submodule update --init --recursive
+ git submodule init
+ git config -f .gitmodules "submodule.harfbuzz/harfbuzz.url" $srcdir/harfbuzz
+ git config -f .gitmodules "submodule.freetype/libpng.url" $srcdir/libpng
+ git config -f .gitmodules "submodule.deps/freetype/zlib.url" $srcdir/zlib
+ git config -f .gitmodules "submodule.freetype2.url" $srcdir/freetype2
+ git submodule update
}
pkgver() {
cd $srcdir/wezterm
- git describe --tags | tr - .
+ git show -s "--format=%cd-%h" "--date=format:%Y%m%d-%H%M%S" | tr - .
}
build() {