summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWez Furlong2020-06-07 03:14:15 -0700
committerWez Furlong2020-06-07 03:16:34 -0700
commit88bed30c50313d06a998b60062f93f99d67dd4d3 (patch)
tree13e4298028de3e484f6b5c3ee8f2f1108266c6e9 /PKGBUILD
downloadaur-88bed30c50313d06a998b60062f93f99d67dd4d3.tar.gz
Add nightly binary build spec
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46c12c92bf16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Wez Furlong <wez at wezfurlong dot org>
+
+pkgname=wezterm-nightly-bin
+pkgver=20200517.122836.92c201c6.105.g5d508350
+pkgrel=1
+pkgdesc='Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust'
+arch=('i686' 'x86_64')
+url='https://wezfurlong.org/wezterm'
+license=('MIT')
+provides=('wezterm')
+# Don't strip: it will break the AppImage!
+options=('!strip')
+depends=('fuse' 'libx11')
+conflicts=('wezterm-bin')
+source=("wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage"
+ 'LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md')
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ chmod +x ${srcdir}/wezterm
+}
+
+pkgver() {
+ ${srcdir}/wezterm --version | cut -d' ' -f2 | tr - .
+}
+
+package() {
+ install -Dm755 wezterm -t "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}