summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuoi2022-08-16 14:43:02 +0100
committerKuoi2022-08-16 14:43:02 +0100
commit39243c898ac437a2dbbd6a29527f8fa86e720d58 (patch)
treea37cd3a820d5311d2a62d22e21606f558467bf37 /PKGBUILD
downloadaur-wf-extra-protos-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..961df6973c42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=wf-extra-protos-git
+_pkgname=wf-extra-protos
+pkgver=r3.8df1337
+pkgrel=1
+pkgdesc="Extra wayland protocol support for wayfire, featuring wf-menu"
+arch=(x86_64)
+url=https://github.com/soreau/wf-extra-protos
+license=(MIT)
+depends=(wayfire gtkmm-4.0)
+makedepends=(meson ninja pkg-config git cmake wayland-protocols glm)
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("git+https://github.com/soreau/wf-extra-protos.git")
+sha256sums=('SKIP')
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ rm -rf build
+ arch-meson "${_pkgname}" build
+ ninja -C build
+}
+
+check () {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+