summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2019-06-03 10:27:35 +0200
committerCedric Girard2019-06-03 10:27:35 +0200
commit757cbf33e08a8f107caea35e3a1b53ffd623db02 (patch)
tree586bfe6c963e13f32945b85343c217b7d546ca78 /PKGBUILD
parent80399b3a19b9e9f6c9fcc072055f63143a4216cb (diff)
downloadaur-757cbf33e08a8f107caea35e3a1b53ffd623db02.tar.gz
upgpkg: wfuzz 2.3.4-3
switched to python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6463d60690c2..3f441e0adbee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
+# Maintainer: Cedric Girard <cgirard.archlinux@valinor.fr>
#Contributor: Olivier Le Moal <mail at olivierlemoal dot fr>
-#Maintainer: Dawid Wrobel <cromo@klej.net>
-#Maintainer: Sébastien Duquette <ekse.0x@gmail.com>
-#Maintainer: onny <onny@project-insanity.org>
+#Contributor: Dawid Wrobel <cromo@klej.net>
+#Contributor: Sébastien Duquette <ekse.0x@gmail.com>
+#Contributor: onny <onny@project-insanity.org>
pkgname=wfuzz
pkgver=2.3.4
-pkgrel=2
+pkgrel=3
pkgdesc="Utility to bruteforce web applications to find their not linked resources"
url="https://github.com/xmendez/wfuzz"
-arch=('i686' 'x86_64')
+arch=('any')
license=('GPL')
-depends=('python2-pycurl' 'python2-pyparsing' 'python2-configparser' 'python2-future')
-makedepends=()
-conflicts=()
-replaces=()
-backup=()
-source=("https://github.com/xmendez/wfuzz/archive/v$pkgver.tar.gz")
-md5sums=('74817cc7aa14efda785c1727622e4539')
-sha256sums=('87ff36d866cb173389f90cf026136758d3af73079a6199961de12ed86568be51')
+depends=('python-pycurl' 'python-pyparsing' 'python-future')
+makedepends=('python-setuptools')
+source=("https://github.com/xmendez/wfuzz/archive/v$pkgver.tar.gz"
+ "https://github.com/xmendez/wfuzz/pull/117.diff")
+sha256sums=('87ff36d866cb173389f90cf026136758d3af73079a6199961de12ed86568be51'
+ 'd320a192f65b8bce8acd2fa285331ab69ea996cbfe76f3d2563de7ccfe11dd0e')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < ../117.diff
+
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
}