summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2020-06-24 20:41:55 +0200
committerKr1ss2020-06-24 20:41:55 +0200
commit1dd5ab6cf89608e94b809f3f508c703112d8877d (patch)
tree4f2de6f5ba47c83eaa5c6b77d04bccbb74393327 /PKGBUILD
parent74baa2c5ddebb28d7c3c865b0e8df87f38be4165 (diff)
downloadaur-1dd5ab6cf89608e94b809f3f508c703112d8877d.tar.gz
take over package from ariasuni
Thank you for maintaining so far !
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 573984bf1da5..20a0d8fbcd92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
-# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+
+
+pkgname=whalebird-bin
-_appname=whalebird
-pkgname="$_appname-bin"
pkgver=4.1.3
-pkgrel=1
-pkgdesc='An Electron based Mastodon client for Windows, Mac and Linux'
-arch=(x86_64)
-url='https://whalebird.org/'
-license=(MIT)
-depends=(c-ares ffmpeg gtk3 http-parser libevent libvpx libxslt libxss minizip nss re2 snappy libnotify libappindicator-gtk3)
-source=("https://github.com/h3poteto/whalebird-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
+pkgrel=2
+
+pkgdesc='Electron based Mastodon client for Windows, Mac and Linux'
+arch=('x86_64')
+url="https://${pkgname%-bin}.org"
+license=('MIT')
+
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
+
+source=("https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
sha256sums=('a661273879bbdded3b33e7d29dcc97b1eac87eaa8be72a372eb2128f7b69db40')
+
package() {
- mkdir -p "$pkgdir/usr/bin"
+ install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/${pkgname%-bin}/"
+ cp -R usr/share/* "$pkgdir/usr/share/"
cp -R opt "$pkgdir/"
- cp -R usr/share "$pkgdir/usr/"
- ln -s /opt/Whalebird/whalebird "$pkgdir/usr/bin/whalebird"
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/Whalebird/${pkgname%-bin}" "$pkgdir/usr/bin/"
}
+
+
+# vim: ts=2 sw=2 et ft=PKGBUILD: