summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-08-01 11:04:57 +0800
committerzxp198210052023-08-01 11:04:57 +0800
commit1f8f56b2e0214139bbc08f764bed8d2385e1cac3 (patch)
tree623d756a48919e6e19b1f6c4a2f1f4eb823b3df6 /PKGBUILD
parent53805cecd9c2b87923e5ea0bf69e6054d2c7a823 (diff)
downloadaur-1f8f56b2e0214139bbc08f764bed8d2385e1cac3.tar.gz
optimized PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e497c657934b..b096f9853b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,27 @@
# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
pkgname=whalebird-bin
pkgver=5.0.7
-pkgrel=1
+pkgrel=2
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
arch=('x86_64')
url="https://whalebird.social/"
_githuburl="https://github.com/h3poteto/whalebird-desktop"
license=('GPL3')
-depends=('glibc' 'pango' 'libxkbcommon' 'libxdamage' 'wayland' 'glib2' 'expat' 'libcups' 'nspr' 'nss' 'mesa' 'libdrm' 'cairo' 'libx11' \
- 'libxcb' 'gcc-libs' 'libxcomposite' 'dbus' 'at-spi2-core' 'hicolor-icon-theme' 'libxext' 'libxrandr' 'libxfixes' 'alsa-lib' 'gtk3')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/Whalebird-${pkgver}-linux-amd64.deb")
-sha256sums=('cd7969a3cc7866e71602a97653f8ff9c9546ca7819886f42f5be5b0501a718c4')
+depends=('bash' 'electron21' 'hicolor-icon-theme')
+provides=("${pkgname%-bin}-${pkgver}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/Whalebird-${pkgver}-linux-amd64.deb"
+ "${pkgname%-bin}.sh")
+sha256sums=('cd7969a3cc7866e71602a97653f8ff9c9546ca7819886f42f5be5b0501a718c4'
+ '17568c4e29671159815f2fb3635ec6d1e43690fd171c2e2ffa3d2d0fe921c690')
package() {
- bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/Whalebird/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ sed "s|/opt/Whalebird/whalebird %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 44x44 50x50 150x150 256x256 310x310;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
} \ No newline at end of file