summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2021-08-05 17:00:06 +0200
committerKr1ss2021-08-05 17:00:06 +0200
commit220d1f4562e28e1330599e2afb48afe806690e4f (patch)
treea11327d848b345a68ee26d6b851d8b6ee5d922d2 /PKGBUILD
parent053c1855ab20592d38c346f36b8e6dde975ada1d (diff)
downloadaur-220d1f4562e28e1330599e2afb48afe806690e4f.tar.gz
update: whalebird-bin 4.4.2-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f7cd99b5f1c..d4551625c1b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,31 @@
pkgname=whalebird-bin
+_name="${pkgname%-bin}"
-pkgver=4.4.1
+pkgver=4.4.2
pkgrel=1
pkgdesc='Electron based multi-platform client for Mastodon, Misskey & Pleroma'
arch=('x86_64')
-url="https://${pkgname%-bin}.org"
+url="https://$_name.org"
license=('MIT')
-provides=("${pkgname%-bin}")
-conflicts=("${pkgname%-bin}")
+provides=("$_name")
+conflicts=("$_name")
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
-source=("https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
+source=("https://github.com/h3poteto/$_name-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
sha256sums=($(curl -sL https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/sha256sum.txt | grep Whalebird-$pkgver-linux-x64.rpm | cut -d\ -f1))
package() {
- install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/${pkgname%-bin}/"
+ install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/$_name/"
cp -R usr/share/* "$pkgdir/usr/share/"
cp -R opt "$pkgdir/"
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/Whalebird/${pkgname%-bin}" "$pkgdir/usr/bin/"
+ ln -s "/opt/Whalebird/$_name" "$pkgdir/usr/bin/"
}