summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorariasuni2020-01-23 01:42:52 +0100
committerariasuni2020-01-23 01:42:52 +0100
commitd4fca2c343ae59f63c143d2a01216481ccd9a17d (patch)
tree5d6717f8b8f3fa212fb3789185aa98432ae0d886 /PKGBUILD
parent6af78b10f89cc77baa35e093c3b5ec2e518ccac6 (diff)
downloadaur-d4fca2c343ae59f63c143d2a01216481ccd9a17d.tar.gz
update to 3.1.0 and don’t rpm specific metadata
Thanks to Kr1ss for the later https://aur.archlinux.org/packages/whalebird-bin/#comment-723992
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8b56f1877d9..4bf9994504c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_appname=whalebird
pkgname="$_appname-bin"
-pkgver=3.0.3
+pkgver=3.1.0
pkgrel=1
pkgdesc='An Electron based Mastodon client for Windows, Mac and Linux'
arch=(x86_64)
@@ -10,10 +10,11 @@ url='https://whalebird.org/'
license=(MIT)
depends=(c-ares ffmpeg gtk3 http-parser libevent libvpx libxslt libxss minizip nss re2 snappy libnotify libappindicator-gtk3)
source=("https://github.com/h3poteto/whalebird-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
-sha256sums=('cab4c85b9760f16bdd88d98a359538894a50e71119d0eda45c0a564072495da8')
+sha256sums=('b751a62a4f7e34c98f6965e11ca479302244545fb8514f7d807fe135fb94384b')
package() {
- cp -R opt/ usr/ "$pkgdir"
- mkdir "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/bin"
+ cp -R opt "$pkgdir/"
+ cp -R usr/share "$pkgdir/usr/"
ln -s /opt/Whalebird/whalebird "$pkgdir/usr/bin/whalebird"
}