summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredy Alberto García Güiza2022-06-21 13:45:30 -0500
committerGitHub2022-06-21 13:45:30 -0500
commit86df4c6821fb63c70e3721731d64caee14f5f4e1 (patch)
tree3801cf13a6e5519afe9ca2888ada69f1de269257 /PKGBUILD
parent819b1a82860570e459ef337c890b3b199bb67387 (diff)
parent345f249caf7f460e18f5d8b0e3e39fe76cddb497 (diff)
downloadaur-86df4c6821fb63c70e3721731d64caee14f5f4e1.tar.gz
Merge branch 'master' into safariFix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 442906c383be..116f51b0363a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fredy García <frealgagu at gmail dot com>
pkgname=whatsapp-nativefier
-pkgver=2.2206.5
+pkgver=2.2206.16
pkgrel=1
pkgdesc="WhatsApp desktop built with nativefier (electron)"
arch=("armv7l" "i686" "x86_64")
@@ -23,7 +23,7 @@ sha256sums=(
build() {
cd "${srcdir}"
-
+
nativefier \
--name "WhatsApp" \
--icon "${pkgname}.png" \
@@ -33,6 +33,7 @@ build() {
--inject "${pkgname}-inject.js" \
--browserwindow-options '{ "webPreferences": { "spellcheck": true } }' \
--verbose \
+ --electron-version 19.0.4 \
--single-instance \
--tray \
"${url}"
@@ -48,8 +49,7 @@ package() {
ln -s "/opt/${pkgname}/${_binary}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${pkgdir}/opt/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
- do
+ for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"; do
install -dm755 "${pkgdir}/usr/share/icons/hicolor/${_size}/apps"
convert "${srcdir}/${pkgname}.png" -strip -resize "${_size}" "${pkgdir}/usr/share/icons/hicolor/${_size}/apps/${pkgname}.png"
done