summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandru2016-07-19 17:00:49 +0000
committerAlexandru2016-07-19 17:00:49 +0000
commit3aacb720d3a44d0992378be709784fafda910281 (patch)
tree13638dc25786d72bda1d0313415cc16e2f2f7328 /PKGBUILD
parentcdfd3f39111fe377eaba3f38a3e6db501df1f782 (diff)
downloadaur-3aacb720d3a44d0992378be709784fafda910281.tar.gz
[CI] v2.0.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d0403598697..9ef764f5b865 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
pkgname=whatsie
-pkgver=2.0.15
-pkgrel=1
+pkgver=2.0.18
+pkgrel=
pkgdesc="A simple & beautiful desktop client for WhatsApp Web."
arch=('x86_64')
-url="https://github.com/Aluxian/Whatsie"
+url="https://whatsie.chat/"
license=('MIT')
-depends=('desktop-file-utils' 'gconf' 'gtk2' 'gvfs' 'hicolor-icon-theme' 'libgudev' 'libgcrypt' 'libnotify' 'libxtst' 'nss' 'python' 'xdg-utils' 'libcap')
-optdepends=('hunspell: spell check')
+depends=('desktop-file-utils' 'gconf' 'gtk2' 'gvfs' 'hicolor-icon-theme' 'libgudev' 'libgcrypt' 'libnotify' 'libxtst' 'nss' 'python' 'xdg-utils' 'libcap' )
+optdepends=('hunspell: spell check' )
options=('!docs' '!emptydirs')
-install=whatsie.install
-source=("whatsie-$pkgver-linux-amd64.deb::https://github.com/Aluxian/Whatsie/releases/download/v$pkgver/whatsie-$pkgver-linux-amd64.deb")
-md5sums=('caeedca3cc47ab414923c1ffa9ec9fca')
+install=$pkgname.install
+source=("https://dl.bintray.com/aluxian/aur/dist/whatsie-2.0.18-linux-amd64.deb")
+validpgpkeys=('6DDA23616E3FE905FFDA152AE61DA9241537994D')
+md5sums=('517c65c9c2c1f3ebda8f1fe8d12345b7')
package() {
msg2 "Extracting the data.tar.gz..."
bsdtar -xf data.tar.gz -C "$pkgdir/"
- # msg2 "Fixing permissions of documentation folder..."
- # chmod -R 775 "$pkgdir/opt/"
- # chmod -R 775 "$pkgdir/etc/"
- # chmod -R 775 "$pkgdir/usr/"
+ # Link to the binary
+ ln -s /opt/whatsie/whatsie "$pkgdir/usr/bin/whatsie"
}