summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBernhard Landauer2016-12-11 00:21:15 +0100
committerBernhard Landauer2016-12-11 00:21:15 +0100
commiteda26f2794512eabf5b2fe6d907fd4e480a4796a (patch)
tree95fb3c5f859e0e923ba20d57642fb514bb0fa026 /PKGBUILD
parenta0edb431e5a98d7dbfd3df4b28fad670a3a3cabb (diff)
downloadaur-eda26f2794512eabf5b2fe6d907fd4e480a4796a.tar.gz
rm .install, proper pkgrel, rm outdated url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98480f2731b2..cc38202f5e75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,26 @@
pkgname=whatsie
pkgver=2.1.0
-pkgrel=683
+pkgrel=2
pkgdesc="A simple & beautiful desktop client for WhatsApp Web."
arch=('x86_64')
-url="https://whatsie.chat/"
+url="https://github.com/gsantner/$pkgname"
license=('MIT')
-depends=('desktop-file-utils' 'gconf' 'gtk2' 'gvfs' 'hicolor-icon-theme' 'libgudev' 'libgcrypt' 'libnotify' 'libxtst' 'nss' 'python' 'xdg-utils' 'libcap' )
+depends=('desktop-file-utils'
+ 'gconf'
+ 'gtk2'
+ 'gvfs'
+ 'hicolor-icon-theme'
+ 'libcap'
+ 'libgcrypt'
+ 'libgudev'
+ 'libnotify'
+ 'libxtst'
+ 'nss'
+ 'python'
+ 'xdg-utils')
optdepends=('hunspell: spell check' )
options=('!docs' '!emptydirs')
-install=$pkgname.install
-source=("https://dl.bintray.com/aluxian/aur/dist/whatsie-2.1.0-linux-amd64.deb")
-validpgpkeys=('6DDA23616E3FE905FFDA152AE61DA9241537994D')
+source=("https://dl.bintray.com/aluxian/aur/dist/$pkgname-$pkgver-linux-amd64.deb")
md5sums=('d2e5cb515503cb9e4ae2f574992772c0')
package() {
msg2 "Extracting the data.tar.gz..."
@@ -19,5 +29,5 @@ package() {
# Link to the binary
msg2 "Creating symlink..."
mkdir -p "$pkgdir/usr/bin/"
- ln -s /opt/whatsie/whatsie "$pkgdir/usr/bin/whatsie"
+ ln -s /opt/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}