summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302019-06-30 22:10:05 +0200
committerM0Rf302019-06-30 22:10:05 +0200
commit6298d813416a85eb1049f9e57277cbecd31b16c0 (patch)
treebfa2699b2c6250e837b91937b619763ded98eda9 /PKGBUILD
parent457a109de2405b1532b7cd87243c083074888086 (diff)
downloadaur-6298d813416a85eb1049f9e57277cbecd31b16c0.tar.gz
whatweb-git: updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af0f7bf0b79e..9303b59f1a84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=whatweb-git
-pkgver=4245.5aa3d5e4
+pkgver=v0.4.9.r440.7885799c
pkgrel=1
pkgdesc="Next generation web scanner that identifies what websites are running."
arch=('i686' 'x86_64')
@@ -10,20 +10,20 @@ conflicts=('whatweb')
provides=('whatweb')
url="http://www.morningstarsecurity.com/research/whatweb"
license=('GPL')
-depends=('ruby1.8')
-source=("whatweb::git://github.com/urbanadventurer/WhatWeb.git")
+depends=('ruby')
+source=("whatweb::git://github.com/urbanadventurer/WhatWeb.git"
+patch)
package() {
- cd whatweb
- sed -i 's/TODO //g' Makefile
- make DESTDIR=$pkgdir install
- sed 's#/usr/bin/env ruby#/usr/bin/ruby-1.8#g' -i ${pkgdir}/usr/bin/whatweb
-
+ cd whatweb
+ patch -Np1 -i ../patch
+ make DESTDIR=$pkgdir install
}
pkgver() {
- cd whatweb
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd whatweb
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-md5sums=('SKIP')
+md5sums=('SKIP'
+'0de7ce37f82d813e06275f6e08a41fa1')