summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNatrio2016-09-20 14:54:29 +0300
committerNatrio2016-09-20 14:54:29 +0300
commitc1faa41ba67d905ff0a859b9697fdd0da753b62c (patch)
tree345a51700f88932174866e6670b5e19953a38ffc /PKGBUILD
downloadaur-c1faa41ba67d905ff0a859b9697fdd0da753b62c.tar.gz
Creating WHDD-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdc3efa608c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natrio <natrio@list.ru>
+
+pkgname=whdd-git
+_pkgname=whdd
+pkgver=2.2.r16.g5da4969
+pkgrel=1
+pkgdesc='HDD diagnostic and recovery tool for Linux'
+url='https://github.com/whdd/whdd'
+arch=(i686 x86_64)
+license=(GPL)
+conflicts=(whdd)
+provides=(whdd)
+depends=(dialog ncurses)
+optdepends=('smartmontools: for reading SMART attributes')
+source=('git+https://github.com/whdd/whdd.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ IFS=- read _v _r < <(git describe)
+ echo "$_v.r${_r//-/.}"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 whdd "$pkgdir/usr/bin/whdd"
+}