summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBastien Traverse2016-12-11 16:38:02 +0100
committerBastien Traverse2016-12-11 16:38:02 +0100
commit4292415a323087ce3bd98d783a4504a8aa430bef (patch)
tree158c0ec5d621c95b403b7d608fb4029c3f9a8129 /PKGBUILD
parent0bc53a402dfd70e063b710507e9d36e1aef76bcb (diff)
downloadaur-4292415a323087ce3bd98d783a4504a8aa430bef.tar.gz
Bump pkgver to latest rev (0.4) and improve PKGBUILD
replace non-standard _gitname variable with string processing bump pkgver to latest major version (v0.4) remove empty optdepends() array remove conflict=() with morituri since whipper uses its own namespace now remove .install file after 7-week warning of backward-incompatible changes parametrize source array to use $pkgname and $url variables (makes it portable accross PKGBUILDs) remove vim options line as it does not appear in reference PKGBUILD.proto
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57c08ca74922..7f2512ea8123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,7 @@
# Based on community/morituri and aur/morituri-git PKGBUILDs
pkgname=whipper-git
-_gitname=whipper
-pkgver=0.2.3.r112.g5a59f3c
+pkgver=0.4.0.r3.g71335e1
pkgrel=1
pkgdesc="A Unix CD ripper aiming for accuracy over speed -- forked from morituri"
arch=('any')
@@ -34,34 +33,30 @@ makedepends=(
'git'
'python2-gobject2'
)
-optdepends=()
provides=('whipper')
-conflicts=('morituri' 'whipper')
-install=$pkgname.install
-source=('git+https://github.com/JoeLametta/whipper.git')
+conflicts=('whipper')
+source=("${pkgname/-git}::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
# Cutting off "v" prefix present in the git tag
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
git submodule init
git submodule update
}
build() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
export PYTHON=$(which python2)
python2 setup.py build
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
python2 setup.py install --root="${pkgdir}"/ --optimize=1
}
-
-# vim: ft=sh:ts=4:sw=4:et