summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Giovannetti2018-12-05 23:39:52 +0800
committerDario Giovannetti2018-12-05 23:39:52 +0800
commitd994131dbcf5ba7f22a22ffdbd2a9d18ac23fd41 (patch)
treee18045b3e53da56482ac089e08da9ee9975acf75 /PKGBUILD
downloadaur-d994131dbcf5ba7f22a22ffdbd2a9d18ac23fd41.tar.gz
Release v5.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c00238755f1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='wiki-monkey'
+# Don't use "-" in pkgver
+pkgver='5.0.0'
+pkgrel=1
+pkgdesc="Wiki Monkey - MediaWiki (ArchWiki-optimized) bot and editor-assistant user script (server-enabled version)."
+arch=('any')
+url="https://github.com/kynikos/wiki-monkey/wiki"
+license=('GPL3')
+# Keep in sync with setup.py's install_requires option and requirements.txt
+depends=('python-configfile'
+ 'python-xdg'
+ 'python-flask-restinpeace' # implies 'python-flask-marshmallow' and 'python-apispec'
+ 'python-flask-cors'
+ 'python-flask-migrate' # implies 'python-flask-sqlalchemy'
+ 'python-marshmallow-sqlalchemy')
+optdepends=('python-pyopenssl: use ad-hoc SSL certificates instead of generating one')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('60144bef4a7a1caa08987949a2547bf7f42df948080dd349f76a5aaddc30605b')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}