summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-03-25 10:58:21 +0430
committerMohammadreza Abdollahzadeh2022-03-25 10:58:21 +0430
commit0cf93728badd73425d64c3f854e71b3575125cf4 (patch)
tree15e0da6572d5021faed7f1ba7eba4493027f61c2 /PKGBUILD
parentad269b983315ec3242eb06fc1d712f63b4d58cd2 (diff)
downloadaur-0cf93728badd73425d64c3f854e71b3575125cf4.tar.gz
fix systemd service file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 133d288a1132..18d5d6f8077e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Zdenek Obst <zdenek dot obst at gmail dot com>
pkgname=wildfly
pkgver=26.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Wildfly Application Server.'
url='http://www.wildfly.org/'
license=('LGPL')
@@ -57,6 +57,8 @@ package() {
echo " -> Creating wildfly.conf (environment settings)..."
install -D -t "${pkgdir}/${_cfgloc}/${pkgname}" -m 644 wildfly.conf
echo " -> Placing wildfly.service in /$_sysdloc..."
+ # fix pid file location
+ sed -i 's|PIDFile=/var/run/wildfly/wildfly\.pid|PIDFile=/run/wildfly/wildfly\.pid|' wildfly.service
install -D -t "${pkgdir}/${_sysdloc}" -m 644 wildfly.service
echo " -> Copying launch.sh to the bin directory..."
install -D -t "${pkgdir}/${_pkgloc}/${pkgname}/bin" -m 755 launch.sh