summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Stroobants2015-09-14 21:10:59 +0200
committerTom Stroobants2015-09-14 21:10:59 +0200
commitd40e91243e7c9e2cfcad1cda8af61779d61cf48c (patch)
tree8230877f16edba74582bdeaf35d645923865ddb3 /PKGBUILD
downloadaur-d40e91243e7c9e2cfcad1cda8af61779d61cf48c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb4b60e1cdb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tom Stroobants <stroobantstom@gmail.com>
+pkgname=willekeur-git
+_command=willekeur
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="On call will change the background to a Google Earth image"
+arch=("any")
+url="https://github.com/stroobantstom/willekeur"
+license=('MIT')
+depends=('curl')
+
+source=("$pkgname"::"git+https://github.com/stroobantstom/willekeur.git")
+
+md5sums=('SKIP') #autofill using updpkgsums
+
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm755 willekeur.sh "${pkgdir}/usr/bin/${_command}"
+ install -Dm755 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file