summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-05-19 15:57:31 +0300
committerKonstantinos2017-05-19 15:57:31 +0300
commitf068eca152452c30c7d8a953ed152e3b61684dce (patch)
treed11fdcae4629ef7c22fdfe3d31dab220f0676bab /PKGBUILD
downloadaur-wily.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e9f5e11ca58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+pkgname=wily
+pkgver=0.13.42
+pkgrel=1
+pkgdesc="A mouse-oriented, text-based environment for programmers."
+arch=('x86_64' 'i686')
+url="https://wily.sourceforge.io"
+license=('custom:Artistic')
+depends=('libxt')
+#makedepends=('')
+provides=("${pkgname}")
+source=("https://downloads.sourceforge.net/project/${pkgname}/baseline/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('5f5498b11c28c8d1fde7750f133a4ab2faca4b23f2ca0a563103ea34e667c4cb')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -D -m644 "Artistic" "${pkgdir}/usr/share/licenses/${pkgname}/Artistic"
+ install -D -m755 "wily/wily" "${pkgdir}/usr/bin/wily"
+}
+
+# vim:set ts=2 sw=2 et: