summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralive4ever2018-12-17 01:08:45 +0000
committeralive4ever2018-12-17 01:08:45 +0000
commit105bead5a1713c3d18aa72bf5ac8646f16bd2a3f (patch)
treea90f995d1ae5b657e266b2fc97a87a1cb33ead3a /PKGBUILD
parenteab2b257ade8d2f692e378b5ef1893faaf67422f (diff)
downloadaur-105bead5a1713c3d18aa72bf5ac8646f16bd2a3f.tar.gz
Fix package build
wimboot needs gcab and doesn't depend on lcab anymore. Also add a patch to recognize R_X86_64_PLT32 relocation in addition to R_X86_64_PC32.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb5961152e27..17b33f0fb6f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Alif <alive4ever at live.com>
pkgname=wimboot-git
-pkgver=v2.5.2.r0.901fe95
+pkgver=v2.6.0.r2.55cfe8a
pkgrel=1
pkgdesc="iPXE kernel to boot wim images from network for both UEFI and BIOS system"
arch=(any)
url="https://git.ipxe.org/wimboot.git"
license=('GPL')
-makedepends=('git' 'pesign' 'lcab')
+makedepends=('git' 'pesign' 'gcab')
optdepends=("ipxe-git: iPXE network boot program"
"ipxe-netboot: Alternative iPXE network boot program, with Archlinux network install support")
install=$pkgname.install
-source=('wimboot::git+https://git.ipxe.org/wimboot.git')
-md5sums=('SKIP')
+source=('wimboot::git+https://git.ipxe.org/wimboot.git'
+ '01-efireloc.diff')
+sha256sums=('SKIP'
+ '6f8184d75ff2c30a19f9192a8d6f159a390a677e6fd110fd4aea79ac14e9f31d')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -19,6 +21,8 @@ pkgver() {
}
build() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 < "$srcdir/01-efireloc.diff"
cd "$srcdir/${pkgname%-git}/src"
make
}