summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Osman2017-12-02 11:30:32 -0800
committerNathan Osman2017-12-02 11:31:04 -0800
commit68f295c6c05c842c006a226cec3ff04a40e2a199 (patch)
treeeca1e91dd39c09c97dda353da9d15ce9d17bedcf /PKGBUILD
downloadaur-win32pe.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d545e1847f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nathan Osman <nathan@quickmediasolutions.com>
+
+pkgname='win32pe'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc="C++ library for working with Win32 PE files"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://github.com/nathan-osman/win32pe"
+makedepends=('cmake' 'boost>=1.58')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/nathan-osman/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('479a8ca8b84c30ff0737d43ab0c80d843c1870d76e77186ad0034e2f9de9eb5e')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file