summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTopik2021-12-23 00:07:55 -0600
committerTopik2021-12-23 00:07:55 -0600
commit1001922370347a174d47666cf85778bb76d88fc1 (patch)
tree9ed1259d4db4269376b696b770879dfd72ae14f9 /PKGBUILD
parent35c5aede6e6382e0a27ec05ade201eff56acfa7b (diff)
downloadaur-1001922370347a174d47666cf85778bb76d88fc1.tar.gz
Fixed messages build error, fixed python2 path, added stunnel patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63ff24e25b3a..aa8efe301cb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ arch=('x86_64')
url="https://github.com/Windscribe/desktop-v2"
license=('GPL2')
depends=('bash' 'iptables' 'procps-ng' 'qt5-base' 'hicolor-icon-theme' 'libnsl' 'curl' 'c-ares' 'qt5-svg' 'protobuf' 'desktop-file-utils' 'icu67')
-makedepends=('git' 'python2' 'go' 'cmake' 'patchelf' 'dpkg' 'ruby' 'rpm-tools')
+makedepends=('git' 'python3' 'python-pip' 'python2' 'go' 'cmake' 'patchelf' 'dpkg' 'ruby' 'rpm-tools')
provides=('windscribe')
# Conflicts commented out for now as there is not an official binary release yet
# conflicts=('windscribe-bin')
install=${pkgname}.install
-source=('desktop-v2::git+https://github.com/Windscribe/desktop-v2#branch=master' 'patch_installqt' 'patch_sourcechanges' 'patch_buildall')
-sha512sums=('SKIP' 'f15f459d1bce294bbd706b07d040ec21eebfdc1cf71f3e384be9fe9ebf089b154d9e6528077e168db161e7ade945eaa1f9d6515aefc5490b1703bd8e1b13fdf8' '231765d8ebd14cccfc2a6f80c48672c3c8baa35101ee21c20c8d877955e23d3090856100fffd1964010344f3479e2fac8843301f315dc8d9a660fb97012a1481' '3d0f6e821967a3c639a86f511a06c321448730b1f485b0b9bf4597ca0a2538d8fa3fb383c9cd55862edbab959598994616e2ff1bb74c853214666870fda90e65')
+source=('desktop-v2::git+https://github.com/Windscribe/desktop-v2#branch=master' 'patch_installqt' 'patch_sourcechanges' 'patch_buildall' 'patch_stunnel')
+sha512sums=('SKIP' 'f15f459d1bce294bbd706b07d040ec21eebfdc1cf71f3e384be9fe9ebf089b154d9e6528077e168db161e7ade945eaa1f9d6515aefc5490b1703bd8e1b13fdf8' '231765d8ebd14cccfc2a6f80c48672c3c8baa35101ee21c20c8d877955e23d3090856100fffd1964010344f3479e2fac8843301f315dc8d9a660fb97012a1481' '3d0f6e821967a3c639a86f511a06c321448730b1f485b0b9bf4597ca0a2538d8fa3fb383c9cd55862edbab959598994616e2ff1bb74c853214666870fda90e65' '78c2d6070b943432930f256508bfe96d461a8201527f2a5249638d1f6d5f9eabefa0d9fcc938974f27fc1fc13f3b10627e506458a92b18c91d9238fc997f021f')
prepare(){
GEM_HOME="$(ruby -e 'puts Gem.user_dir')"
@@ -26,16 +26,22 @@ prepare(){
patch "${srcdir}"/desktop-v2/tools/deps/custom_qt/source_changes.json patch_sourcechanges
# Removed fakeroot when building deb package as to not cause a nested fakeroot
patch "${srcdir}"/desktop-v2/tools/build_all.py patch_buildall
-
+ # Patched stunnel version
+ patch "${srcdir}"/desktop-v2/tools/vars/stunnel.yml patch_stunnel
+
+ python -m pip install messages
+
if [ ! -d "${srcdir}"/py2 ]; then
mkdir "${srcdir}"/py2
- PATH="${srcdir}"/py2:$PATH
ln -s /usr/bin/python2 "${srcdir}"/py2/python
fi
+
+ export PATH="${srcdir}"/py2:$PATH
cd "${srcdir}"/desktop-v2/tools
python bin/get-pip.py
python -m pip install -r requirements.txt
+ python -m pip install message
}
build() {