summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnish Bhatt2013-09-08 19:02:54 -0700
committerAnish Bhatt2013-09-08 19:02:54 -0700
commit29eaf16f96d650aeaac7b914988c6da3fcf66de9 (patch)
tree1f6a91b97b61cc3361df12b90d4cfb39afb57e63 /PKGBUILD
parentde3d209dd5c705c9fd8706fc5cc23789d54a7a4f (diff)
downloadaur-29eaf16f96d650aeaac7b914988c6da3fcf66de9.tar.gz
support all silverlight versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11099bd2b55f..2d48db73d897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Anish Bhatt <anish [at] gatech [dot] edu>
pkgname=wine-browser-installer
pkgver=1
-pkgrel=4
+pkgrel=5
epoch=
pkgdesc="Browser installer for wine-silverlight, shared between netflix-desktop and pipelight"
arch=('any')
@@ -33,6 +33,14 @@ prepare() {
sed -i '4s|^|WINEARCH=win32 |g' wine-silverlight4-installer.install-script
sed -i '6s|^|WINEARCH=win32 |g' wine-silverlight4-installer.install-script
sed -i '6s|@@PACKAGE@@|SilverlightSetup|g' wine-silverlight4-installer.install-script
+
+ sed -i '4s|^|WINEARCH=win32 |g' wine-silverlight5.1-installer.install-script
+ sed -i '6s|^|WINEARCH=win32 |g' wine-silverlight5.1-installer.install-script
+ sed -i '6s|@@PACKAGE@@|wine-silverlight5.1-installer.exe|g' wine-silverlight5.1-installer.install-script
+
+ sed -i '4s|^|WINEARCH=win32 |g' wine-silverlight5.0-installer.install-script
+ sed -i '6s|^|WINEARCH=win32 |g' wine-silverlight5.0-installer.install-script
+ sed -i '6s|@@PACKAGE@@|wine-silverlight5.0-installer.exe|g' wine-silverlight5.0-installer.install-script
}
package() {
@@ -46,6 +54,8 @@ package() {
popd
pushd debian
install -Dm755 wine-silverlight4-installer.install-script "${pkgdir}"/usr/share/wine-silverlight/.
+ install -Dm755 wine-silverlight5.1-installer.install-script "${pkgdir}"/usr/share/wine-silverlight/.
+ install -Dm755 wine-silverlight5.0-installer.install-script "${pkgdir}"/usr/share/wine-silverlight/.
popd
# Install MIT license
install -Dm644 "debian/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/Copyright.txt"