summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Franco2016-05-18 20:10:54 +0200
committerPierre Franco2016-05-18 20:10:54 +0200
commitfd11675260896dc3aeed92939746508170e69429 (patch)
tree393d0ce5f1ea0e5e192da8acc601daa7a39d0ec3 /PKGBUILD
parentee94d0f072229583c72a143015e818fe063b96de (diff)
downloadaur-fd11675260896dc3aeed92939746508170e69429.tar.gz
Updated to version 1.9.10-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 31 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c98ce55a489..e258e77f8fce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Based on wine-staging PKGBUILD
#Additional patches:
+# -Gallium Nine support
# -Mip-Map fix (see https://bugs.winehq.org/show_bug.cgi?id=34480 )
# -Keybind patch reversion
# -Heap allocation perfomance improvement patch
@@ -9,27 +10,29 @@
# -Steam patch, Crossover Hack version (see https://bugs.winehq.org/show_bug.cgi?id=39403 )
pkgname=wine-gaming-nine
-pkgver=1.9.9
+pkgver=1.9.10
pkgrel=1
_pkgbasever=${pkgver/rc/-rc}
-_winesrcdir="wine-patched-nine-staging-nine-v$_pkgbasever"
-
-source=("https://github.com/mradermaxlol/wine-patched-nine/archive/staging-nine-v$_pkgbasever.tar.gz"
- 30-win32-aliases.conf
- heap_perf.patch
- keybindings.patch
- mipmap.patch
- steam.patch
- wbemprox_query_v2.patch
+_winesrcdir="wine-patched-staging-$_pkgbasever"
+
+source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbasever.tar.gz"
+ "https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-$_pkgbasever.tar.gz"
+ 30-win32-aliases.conf
+ heap_perf.patch
+ keybindings.patch
+ mipmap.patch
+ steam.patch
+ wbemprox_query_v2.patch
)
-sha1sums=('af040bfe14ec2e77e3232a7834f4abf68a38c7a7'
- '023a5c901c6a091c56e76b6a62d141d87cce9fdb'
- '0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd'
- 'f3febb8836f38320742a546c667106608d4c4395'
- 'c3096fccbac23e520d03f592db7f23350cbbc0bc'
- '74aae040fde9ff3c9e8da9c840557e87afdbc3a0'
- '644e141125a9f2407e64d23c85ec84a691c7caae'
+sha1sums=('a5dee79ebfb217c37695c20d841170b8813f040b'
+ 'ce3cfd7340c32e99b714c4fc19381ab951db08bd'
+ '023a5c901c6a091c56e76b6a62d141d87cce9fdb'
+ '0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd'
+ 'f3febb8836f38320742a546c667106608d4c4395'
+ 'c3096fccbac23e520d03f592db7f23350cbbc0bc'
+ '74aae040fde9ff3c9e8da9c840557e87afdbc3a0'
+ '644e141125a9f2407e64d23c85ec84a691c7caae'
)
pkgdesc="Based off wine-staging, including the gallium-nine patches and some more hacks"
@@ -127,18 +130,20 @@ fi
prepare()
{
- cd "$_winesrcdir"
+ cd wine-patched-staging-$_pkgbasever
- sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+ patch -p1 < "$srcdir/wine-d3d9-patches-wine-d3d9-$_pkgbasever/staging-helper.patch" #for wine-staging
+ patch -p1 < "$srcdir/wine-d3d9-patches-wine-d3d9-$_pkgbasever/wine-d3d9.patch"
+ patch -p1 < ../steam.patch
+ patch -p1 < ../mipmap.patch
+ patch -p1 < ../heap_perf.patch
+ patch -p1 < ../wbemprox_query_v2.patch
- patch -p1 < "$srcdir/heap_perf.patch"
- patch -p1 -R < "$srcdir/keybindings.patch"
- patch -p1 < "$srcdir/mipmap.patch"
- patch -p1 < "$srcdir/steam.patch"
- patch -p1 < "$srcdir/wbemprox_query_v2.patch"
+ patch -p1 -R < ../keybindings.patch
autoreconf -f
+ sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
cd $srcdir
@@ -164,6 +169,7 @@ build()
--with-xattr \
--with-d3dadapter \
--disable-tests
+ # Gstreamer was disabled for FS#33655
make
@@ -185,6 +191,7 @@ build()
--with-d3dadapter \
"${_wine32opts[@]}"
+ # These additional flags solve FS#23277
make
}