summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-03-08 14:08:15 -0300
committerDaniel Bermond2022-03-08 14:08:15 -0300
commit46a6baf0cc012b24eb2b0f74253f54e53b248c5d (patch)
tree9adc1e3f143f91d820391fe25de24a7c639a6aa8 /PKGBUILD
parent1394e322e7c15d96d980eebf66f9f953dc06ad23 (diff)
downloadaur-46a6baf0cc012b24eb2b0f74253f54e53b248c5d.tar.gz
Disable lto to match repository package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd65df5b9e4c..9f791054b6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: sxe <sxxe@gmx.de>
pkgname=wine-git
-pkgver=6.22.r0.g986254d6c17
+pkgver=7.3.r297.g99ef287bb72
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (git version)'
arch=('x86_64')
@@ -84,7 +84,7 @@ optdepends=(
'samba'
'dosbox'
)
-options=('staticlibs')
+options=('staticlibs' '!lto')
install="${pkgname}.install"
provides=("wine=${pkgver}" "bin32-wine=${pkgver}" "wine-wow64=${pkgver}")
conflicts=('wine' 'bin32-wine' 'wine-wow64')
@@ -112,9 +112,7 @@ pkgver() {
}
build() {
- # workaround for FS#55128
- # https://bugs.archlinux.org/task/55128
- # https://bugs.winehq.org/show_bug.cgi?id=43530
+ # does not compile without remove these flags as of 4.10
export CFLAGS="${CFLAGS/-fno-plt/}"
export LDFLAGS="${LDFLAGS/,-z,now/}"