summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2022-10-10 19:01:45 -0700
committerMike Swanson2022-10-10 19:01:45 -0700
commit4aaedffa9fd9999e7fb6f069ab614c0316c613a0 (patch)
tree9b589673c2392b12a801a67dea1fe0926b908f5a /PKGBUILD
parent9be2da32b15ac9de190c9ca8edfa48e66924df96 (diff)
downloadaur-4aaedffa9fd9999e7fb6f069ab614c0316c613a0.tar.gz
Move CFLAGS/LDFLAGS assignment to build()
No compilation happens in prepare(), so it makes more logical sense to be in build(). It also happens to fix AUR managers like yay that will execute “makepkg -o” and “makepkg -e --noprepare” independently.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bd80d4aaf1a..b1b849487952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=wine-stable
_pkgver=7.0
pkgver=${_pkgver/-/} # Useful for wine-stable-next
-pkgrel=3
+pkgrel=4
source=(https://dl.winehq.org/wine/source/7.0/wine-$_pkgver.tar.xz{,.sign}
30-win32-aliases.conf
@@ -112,10 +112,6 @@ prepare() {
fi
done
- # https://bugs.winehq.org/show_bug.cgi?id=43530
- export CFLAGS="${CFLAGS/-fno-plt/}"
- export LDFLAGS="${LDFLAGS/,-z,now/}"
-
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i wine/configure*
# Fix openldap 2.5+ detection
@@ -128,6 +124,11 @@ prepare() {
build() {
cd "$srcdir/wine-64-build"
+
+ # https://bugs.winehq.org/show_bug.cgi?id=43530
+ export CFLAGS="${CFLAGS/-fno-plt/}"
+ export LDFLAGS="${LDFLAGS/,-z,now/}"
+
../wine/configure \
--prefix=/usr \
--libdir=/usr/lib \