summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-03-28 16:24:12 -0300
committerBermond2016-03-28 16:24:12 -0300
commit415cba6692fb6f041fc8f1c83e9bbe7827d5d6b3 (patch)
treecea87e2b7a3e755ba568e31b68ba34bd354e815a /PKGBUILD
parent717c113761c945195aca39f18a7aaf2ef88094e1 (diff)
downloadaur-415cba6692fb6f041fc8f1c83e9bbe7827d5d6b3.tar.gz
Fix patchisntall error
Before applying wine-staging patches it's necessary to change back to the wine upstream commit that the current wine-staging version is based in.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d56dbc64c615..d3cc4409171c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=wine-staging-git
-pkgver=1.9.6.r34.g96fddf8+wine.1.9.6.r144.g4315cae
-pkgrel=2
+pkgver=1.9.6.r37.g0a391fa+wine.1.9.6.r144.g4315cae
+pkgrel=1
pkgdesc="A compatibility layer for running Windows programs (staging branch, Git version)"
arch=('i686' 'x86_64')
url="https://github.com/wine-compholio/wine-staging/"
@@ -129,6 +129,9 @@ prepare() {
#+otherwise the patches will fail to be reapplied)
git reset --hard HEAD # Restore tracked files
git clean -d -x -f # Delete untracked files
+
+ # Change back to the wine upstream commit that this version of wine-staging is based in
+ git checkout $(../"$pkgname"/patches/patchinstall.sh --upstream-commit)
}
build() {