summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-03-07 16:05:12 +0000
committerDaniel Bermond2020-03-07 16:05:12 +0000
commit714c8bd82cbcf0405c56c5572c75167a34e6a2e0 (patch)
treea463bbb70c8d06766db4b7857d09fc708cd0d776 /PKGBUILD
parenta6d26e3132a775d46b564d8cc7d38523d33b7e67 (diff)
downloadaur-714c8bd82cbcf0405c56c5572c75167a34e6a2e0.tar.gz
depends: add faudio. Disable xactengine-initial patchset.
faudio is used in repository package since version 5.2-2[1]. The recently introduced xactengine-initial patchset causes a build error with winegcc when building xaudio2_7 tests: /usr/bin/ld: cannot find -lx3daudio1_7 Apparently, this is being caused by the recent upstream commit 2fc5c88[2] that adds the xactengine-initial patchset. Temporarily disable this recently introduced patchset so that the package can be built. References ---------- [1] https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/wine-staging&id=f1617c6f55896ec22573a42912964f9f3e108bf9 [2] https://github.com/wine-staging/wine-staging/commit/2fc5c88068e3dea2612c182ff300511aa2954242
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa64b929e100..80686e38590d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=wine-staging-git
-pkgver=4.20.r4.ga9639c41+wine.4.20.r74.ga9c4b309f6
+pkgver=5.3.r14.g5213d551+wine.5.3.r139.g4f53be1a6e
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
arch=('i686' 'x86_64')
@@ -22,6 +22,7 @@ _depends=(
'libsm' 'lib32-libsm'
'gcc-libs' 'lib32-gcc-libs'
'libpcap' 'lib32-libpcap'
+ 'faudio' 'lib32-faudio'
'desktop-file-utils'
)
makedepends=('git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex'
@@ -146,10 +147,10 @@ prepare() {
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
- # apply all wine-staging patches
+ # apply wine-staging patches (exclude xactengine-initial due to build error)
printf '%s\n' ' -> Applying wine-staging patches...'
cd "${srcdir}/wine-staging/patches"
- ./patchinstall.sh DESTDIR="${srcdir}/wine" --all
+ ./patchinstall.sh DESTDIR="${srcdir}/wine" --all -W xactengine-initial
}
pkgver() {