summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-03-04 16:23:24 -0300
committerDaniel Bermond2018-03-04 16:23:24 -0300
commit96cde2bedb567aefafb3429497dfb46d2a3656cd (patch)
tree9956de92a40cdb91d5d5beb05ae122d511e7fb6c /PKGBUILD
parent3fa525377754a7010d58253d4c7aa2c5ba87cbbc (diff)
downloadaur-96cde2bedb567aefafb3429497dfb46d2a3656cd.tar.gz
Change source. Other modifications.
Upstream wine-staging hosted at 'https://github.com/wine-compholio/wine-staging/' is no more maintained. A community fork is now maintained at 'https://github.com/wine-staging/wine-staging/'. This fork was received by mainstream Arch Linux in it's official repositories in the stable wine-staging package, so it seems to be safe to use it here too. Probably other mainstream Linux distributions will follow this fork too, like Gentoo. Other modifications on this commit: ----------------------------------- - added freetype harmony fix - added wine binfmt - makedepends: added {lib32-}vulkan-icd-loader and {lib32-}sdl2 - optdepends : added {lib32-}sdl2 - optdepends : removed {lib32-}libtxc_dxtn Note: ----- libtxc_dxtn is now integrated into mesa. Packages libtxc_dxtn and lib32-libtxc_dxtn were dropped from the official repositories. References: ----------- https://wine-staging.com/news/2018-02-17-future-wine-staging.html https://www.winehq.org/pipermail/wine-devel/2018-February/122848.html https://www.winehq.org/pipermail/wine-devel/2018-February/123080.html https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/wine-staging&id=1a48e921ac7aa7f9c622f20e384e14324a609fa3 https://lists.freedesktop.org/archives/mesa-dev/2017-October/171265.html https://cgit.freedesktop.org/mesa/mesa/commit/?id=04396a134f003aece573df593acfa1ab4418ffe8 https://cgit.freedesktop.org/mesa/mesa/commit/?id=f7daa737d17df6d0a847e5c61e48d25e598671f4 https://cgit.freedesktop.org/mesa/mesa/commit/?id=d400348c73f0901eb24ff4d1562043d3119ef439 https://bugs.archlinux.org/task/56660 https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mesa&id=8b2dc9909803d680f67bb3d559d3e1c0a5f1e2ec
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ec5c9469eeb..fa8f5217e58a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=wine-staging-git
-pkgver=2.21.r0.g90679f2f+wine.2.21.r0.g53290d2ec4
+pkgver=3.3.r0.ge09e1fd3+wine.3.3.r0.gf17120d11b
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
arch=('i686' 'x86_64')
@@ -47,6 +47,8 @@ makedepends=('git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex'
'libva' 'lib32-libva'
'gtk3' 'lib32-gtk3'
'gst-plugins-base-libs' 'lib32-gst-plugins-base-libs'
+ 'vulkan-icd-loader' 'lib32-vulkan-icd-loader'
+ 'sdl2' 'lib32-sdl2'
'samba'
'opencl-headers'
)
@@ -67,22 +69,27 @@ optdepends=(
'ncurses' 'lib32-ncurses'
'opencl-icd-loader' 'lib32-opencl-icd-loader'
'libxslt' 'lib32-libxslt'
- 'libtxc_dxtn' 'lib32-libtxc_dxtn'
'libva' 'lib32-libva'
'gtk3' 'lib32-gtk3'
'gst-plugins-base-libs' 'lib32-gst-plugins-base-libs'
'vulkan-icd-loader' 'lib32-vulkan-icd-loader'
+ 'sdl2' 'lib32-sdl2'
'cups'
'samba'
'dosbox'
)
options=('staticlibs')
+install="$pkgname".install
source=('wine-git'::'git://source.winehq.org/git/wine.git'
- "$pkgname"::'git+https://github.com/wine-compholio/wine-staging.git'
- '30-win32-aliases.conf')
+ "$pkgname"::'git+https://github.com/wine-staging/wine-staging.git'
+ 'harmony-fix.diff'
+ '30-win32-aliases.conf'
+ 'wine-binfmt.conf')
sha256sums=('SKIP'
'SKIP'
- '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7')
+ '50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1'
+ '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
+ '6dfdefec305024ca11f35ad7536565f5551f09119dda2028f194aee8f77077a4')
if [ "$CARCH" = 'i686' ]
then
@@ -123,6 +130,9 @@ prepare() {
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+
+ # freetype harmony fix
+ patch -Np1 -i "${srcdir}/harmony-fix.diff"
}
pkgver() {
@@ -213,5 +223,8 @@ package() {
# font aliasing settings for Win32 applications
install -d "$pkgdir"/etc/fonts/conf.{avail,d}
install -m644 "${srcdir}/30-win32-aliases.conf" "${pkgdir}/etc/fonts/conf.avail"
- ln -s ../conf.avail/30-win32-aliases.conf "${pkgdir}/etc/fonts/conf.d/30-win32-aliases.conf"
+ ln -s ../conf.avail/30-win32-aliases.conf "${pkgdir}/etc/fonts/conf.d/30-win32-aliases.conf"
+
+ # wine binfmt
+ install -D -m644 "${srcdir}/wine-binfmt.conf" "${pkgdir}/usr/lib/binfmt.d/wine.conf"
}